Nomad Lingo

now requires the FLASH 5 plug-in

& is best viewed at 1024 X 768 resolution on a 4.0+ browser

>>>>>enter here

Since April this site has been constructed using FLASH 4

if you have the FLASH 4 plug-in & don't want to bother getting the new FLASH 5 plug-in immediately &wish to visit the site updated to the month of October, 2000

>>enter here for old FLASH 4 site

or

>>get the FLASH 5 plug-in

(why not? its free)